GitHub Advisoryadvisory · npm

GHSA-xq8m-7c5p-c2r6 Auth0 Next.js SDK has Improper Proxy Cache Lookup

MEDIUM Published 2026-04-21 Modified 2026-04-21 Official page ↗
Aliases
CVE-2026-40155
Ecosystem
npm
Packages
@auth0/nextjs-auth0
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:L/A:N
Weaknesses
CWE-362, CWE-863
Reviewed
2026-04-21

Affected packages

• npm @auth0/nextjs-auth0: >= 4.12.0, < 4.18.0 → fixed in 4.18.0

Description

Description In affected versions of the Next.js SDK, simultaneous requests that trigger a nonce retry may cause the proxy cache fetcher to perform improper lookups for the token request results. Which Projects are Affected? Users are affected if they meet all of the following preconditions: • Applications using the auth0/nextjs-auth0 SDK, versions 4.12.0 to 4.17.0, and • Applications using the proxy handler /me/* and /my-org/* with DPoP enabled. Affected product and versions Auth0/nextjs-auth0 v4.12.0 to 4.17.0 Resolution Upgrade Auth0/nextjs-auth0 version to v4.18.0 or greater Acknowledgements Okta would like to thank Reynaldo Immanuel for their discovery and responsible disclosure.

Related

Alias · CVE (1)

  • CVE-2026-40155 The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. vulnerability

Weakness · CWE (2)

  • CWE-362 Concurrent Execution using Shared Resource with Improper Synchronization weakness
  • CWE-863 Incorrect Authorization weakness

References