GitHub Advisoryadvisory · Packagist
GHSA-xwf2-53mc-r8hx phpMyAdmin CSRF Vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2018-19969
- Ecosystem
- Packagist
- Packages
- phpmyadmin/phpmyadmin
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-352
- Reviewed
- 2023-07-24
Affected packages
• Packagist phpmyadmin/phpmyadmin: >= 4.8, < 4.8.4 → fixed in 4.8.4
• Packagist phpmyadmin/phpmyadmin: >= 4.7, <= 4.7.6 (no fix yet)
Description
phpMyAdmin 4.7.x and 4.8.x versions prior to 4.8.4 are affected by a series of CSRF flaws. By deceiving a user into clicking on a crafted URL, it is possible to perform harmful SQL operations such as renaming databases, creating new tables/routines, deleting designer pages, adding/deleting users, updating user passwords, killing SQL processes, etc.
Related
Alias · CVE (1)
- CVE-2018-19969 phpMyAdmin 4.7.x and 4.8.x versions prior to 4.8.4 are affected by a series of CSRF flaws. vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness