GitHub Advisoryadvisory · Maven

GHSA-5c4f-pxmx-xcm4 Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions (4.0.16 only)

HIGH Published 2025-08-25 Modified 2025-08-25 Official page ↗
Aliases
CVE-2025-26467
Ecosystem
Maven
Packages
org.apache.cassandra:cassandra-all
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-267
Reviewed
2025-08-25

Affected packages

• Maven org.apache.cassandra:cassandra-all: >= 4.0.16, < 4.0.17 → fixed in 4.0.17

Description

Privilege Defined With Unsafe Actions vulnerability in Apache Cassandra. An user with MODIFY permission ON ALL KEYSPACES can escalate privileges to superuser within a targeted Cassandra cluster via unsafe actions to a system resource. Operators granting data MODIFY permission on all keyspaces on affected versions should review data access rules for potential breaches. This issue affects Apache Cassandra 3.0.30, 3.11.17, 4.0.16, 4.1.7, 5.0.2, but this advisory is only for 4.0.16 because the fix to CVE-2025-23015 was incorrectly applied to 4.0.16, so that version is still affected. Users in the 4.0 series are recommended to upgrade to version 4.0.17 which fixes the issue. Users from 3.0, 3.11, 4.1 and 5.0 series should follow recommendation from CVE-2025-23015.

Related

Alias · CVE (1)

  • CVE-2025-26467 Privilege Defined With Unsafe Actions vulnerability in Apache Cassandra. vulnerability

Weakness · CWE (1)

  • CWE-267 Privilege Defined With Unsafe Actions weakness

References