GitHub Advisoryadvisory · PyPI

GHSA-6m9r-7wrx-xmr6 Apache Airflow Cross-Site Request Forgery vulnerability

MEDIUM Published 2023-12-21 Modified 2024-11-21 Official page ↗
Aliases
CVE-2023-49920
Ecosystem
PyPI
Packages
apache-airflow
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
Weaknesses
CWE-352
Reviewed
2023-12-21

Affected packages

• PyPI apache-airflow: >= 2.7.0, < 2.8.0 → fixed in 2.8.0

Description

Apache Airflow, version 2.7.0 through 2.7.3, has a vulnerability that allows an attacker to trigger a DAG in a GET request without CSRF validation. As a result, it was possible for a malicious website opened in the same browser - by the user who also had Airflow UI opened - to trigger the execution of DAGs without the user's consent. Users are advised to upgrade to version 2.8.0 or later which is not affected

Related

Alias · CVE (1)

  • CVE-2023-49920 Apache Airflow, version 2.7.0 through 2.7.3, has a vulnerability that allows an attacker to trigger a DAG in a GET request without CSRF… vulnerability

Weakness · CWE (1)

  • CWE-352 Cross-Site Request Forgery weakness

References